Harley Davidson V-Rod Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I just had my bike into the dealer about a month ago to have everything changed out to chrome. I also had the rear brake caliper chromed. Since then I drive my bike for about 30 miles and the belt comes loose. Does anyone know what the problem is? Is it the dealer?
 

·
Color me Gone
Joined
·
27,333 Posts
When you say the belt comes loose, are you saying that it starts to flap?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Yes, I starts to hit the guards. I never had that problem before. Just after Longhorn changed everything out for me. Also, looking for a "GOOD" V-Rod mechanic in the DFW area.
 

·
Color me Gone
Joined
·
27,333 Posts
yellowcat2000 if the belt is hitting the belt guard especially in high gear at low rpm then I would guess that they did not get your belt set at the proper amount of tension.

Max
 

·
Greg/Moderator
Joined
·
18,951 Posts
Had the same porblem with mine I complaind about it during my 1000 mile check up. On the way home still had the same problem, belt hitting lower belt guard in high gears. I put the bike on the lift and snug it up untill the problem was gone, it might take a couple of tries but it can be fixed [ make sure that the axle is square in the swing arm this is critical so the bike doesn't pull]. This is not a tough fix if you dont have the chrome axles covers on, if so it will take a little more work but well worth your effort. Good luck and take your time and make sure everything is tight.
 

·
Banned
Joined
·
12,582 Posts
Get a Chain!:icon_twis;)
 

·
DuPage County
Joined
·
419 Posts
Even at the proper tension, the belt can still hit the guards, especially when lugging it in 4th or 5th.

Don't lug it I guess.

C
 
1 - 13 of 13 Posts
Top