Harley Davidson V-Rod Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello, need some help. I bought my bike used and it has a chrome slotted belt guards, but the upper is rubbing on tank and rear tire. I need to put a new tire on and would like to fix this before it goes on. Is it possible that the previous owner installed the wrong guard? Is there different ones for 180 tire vs 240 tire? Considering taking it to a buddies machine shop and shaving off the edge on a belt sander but worried it will damage the chrome. Any help or suggestions would be great! Thanks
 

·
Departed the Fix.
Joined
·
5,136 Posts
There were a documented number of tanks that had issues with "swelling" tanks. Funnily enough, in 2011 the fuel tank got a revision (part #62921-07 went to 62921-07A). Coincidence? who knows. I'm about 99% sure I had one on my 2012 F. H-D pretty much said "too bad for you" despite multiple sources of evidence and my bike being bone stock (at least regarding the fuel system).

The dealer was sympathetic, but I got shot down by the regional rep, who threw shade on my belt tension as being the cause-- despite it measuring properly in spec with the H-D tool and with the drivetrain properly aligned.

The Catch-22 for me was that H-D *might* warranty the claim IF they did the tear-down. But if they didn't, then I'd be on the hook for all of the labor charges.

I finally gave up, got a new tank and did the install myself.

They'e not great, but if you look at this post, you can see where the bottom of the tank was bowing out. The replacement tank was as straight as a ruler.

https://www.1130cc.com/forums/showpost.php?p=4053754&postcount=560

Just so you know-- maybe it helps, maybe it doesn't.

R.
 

·
Registered
Joined
·
14 Posts
Hi, I had issues with upper belt guard rubbing against tank. The bike was early model 2005 and installed larger U/E tank 20 litres. After some investigating found to be right hand side rear engine mount, easy one to get off. Over the years the metal insert in the rubber casing had pushed back and wasn't centered. When I replaced the right side only the problem was solved. Worth a look first. You'll know what I mean when you at it.
 

·
Registered
Joined
·
402 Posts
Shave Belt Guard

Hello, need some help. I bought my bike used and it has a chrome slotted belt guards, but the upper is rubbing on tank and rear tire. I need to put a new tire on and would like to fix this before it goes on. Is it possible that the previous owner installed the wrong guard? Is there different ones for 180 tire vs 240 tire? Considering taking it to a buddies machine shop and shaving off the edge on a belt sander but worried it will damage the chrome. Any help or suggestions would be great! Thanks
Just shave it where it's rubbing. I got an early 180 model chrome slotted guard and I put it on my '12 Trask Turbo Muscle that has the 240 wheel. There's probably pics of it here on one or more of my posts. I didn't damage the chrome either and it looked good. Don't know why H-D stopped making them chrome slotted guard because it's by far the nicest belt guard there is for the V-Rod. But they stopped making the V-Rod all together so who knows what's going on behind the closed doors at H-D. May as well discontinue the fastest most reliable model they ever produced eh?
 
1 - 6 of 6 Posts
Top