Harley Davidson V-Rod Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hey guys, desperately need your help!

So after a bad battery removal, mybike Won’t start. Blinkers turn on alternately when I switch to On, and will continue to flash after it’s set back to off. A local shop says my ECM&TSSM are trash.
I’m looking on eBay to buy an ECM&TSSM kit that’s already mated.
Have any ideas?
Know someone selling this used or new?
Should it come mated already?

there is no local dealer in my country. This happened to me on the second day of purchasing the bike.
 

·
The Hawk
Joined
·
3,906 Posts
Sounds like the security system. Does your FOB have the push button? If so push it and see if it works.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
Sounds like the security system. Does your FOB have the push button? If so push it and see if it works.


Sent from my iPad using Tapatalk
hi, it doesn’t have a button. Thanks for replying. I’m pretty sure it’s a simple fix, but where I live, there is no Harley dealer.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
This is a security issue as mentioned, not the ECM. Something as simple as a weak fob battery will do that.
Ron
I’ve tried all I’ve been suggested here, plus all I’ve read at other places. Nothing seems to make it work again. Cant even get into PIN mode. I’ll press both turn signals, and nothing.
 

·
Registered
Joined
·
3 Posts
Have you tried going through any of this procedure? I find it hard to believe your TSSM/ECU catastrophically failed just from disconnecting the battery. This is for an earlier model with the button on the fob, but you should be able to verify if the TSSM is working properly with steps 1-3.

Followed these steps...............

Key FOB Assignment:
Procedure must be completed with no pauses between steps greater than 10 seconds.
1) Set RUN/OFF switch to OFF and verify that vehicle is disarmed (security lamp is not blinking).
2) Turn IGN key ON-OFF-ON-OFF-ON
3) Press left turn switch 2 times. The indicators and signals will flash indicating vehicle configuration:
1 flash indicates TSM with no security features
2 flashes indicates North American/Domestic TSSM
3 flashes indicates European/HDI TSSM
4) Press right turn switch 1 time. Indicators and signals will flash 1 time.
5) Press left turn switch 1 time. Indicators and signals will flash 2 times.
6) Press and hold FOB button until confirmation is seen: Indicators and signals will flash 2 times. This confirmation could take 10 to 25 seconds.
7) If there is another FOB to assign press and hold second FOB button until confirmation is seen: Indicators and signals will flash 2 times.
8) Turn IGN key OFF

 

·
Registered
Joined
·
10 Posts
Discussion Starter · #7 ·
Have you tried going through any of this procedure? I find it hard to believe your TSSM/ECU catastrophically failed just from disconnecting the battery. This is for an earlier model with the button on the fob, but you should be able to verify if the TSSM is working properly with steps 1-3.

Followed these steps...............

Key FOB Assignment:
Procedure must be completed with no pauses between steps greater than 10 seconds.
1) Set RUN/OFF switch to OFF and verify that vehicle is disarmed (security lamp is not blinking).
2) Turn IGN key ON-OFF-ON-OFF-ON
3) Press left turn switch 2 times. The indicators and signals will flash indicating vehicle configuration:
1 flash indicates TSM with no security features
2 flashes indicates North American/Domestic TSSM
3 flashes indicates European/HDI TSSM
4) Press right turn switch 1 time. Indicators and signals will flash 1 time.
5) Press left turn switch 1 time. Indicators and signals will flash 2 times.
6) Press and hold FOB button until confirmation is seen: Indicators and signals will flash 2 times. This confirmation could take 10 to 25 seconds.
7) If there is another FOB to assign press and hold second FOB button until confirmation is seen: Indicators and signals will flash 2 times.
8) Turn IGN key OFF

It doesn’t work, it’ll never stop blinking. I changed the 9Volt battery that goesin the siren, and now it doesn’t even chirp, it’ll just flashthe turn signals alternately even if I turn it off. I’m desperate with this now. I’m thinking of buying a thunder max ecu and bypass the alarm system. We don’t have a Harley dealer in this country
 

·
The Hawk
Joined
·
3,906 Posts
Change the battery in the FOB?

Sent from my LM-G820 using Tapatalk
 
1 - 8 of 8 Posts
Top