Harley Davidson V-Rod Forum banner
1 - 8 of 8 Posts

·
Registered
2012 VRSCF
Joined
·
63 Posts
Discussion Starter · #1 ·
I recently bought a 2012 VRSCF and it came with the V&H pipes installed. I’ve been noticing a lot of backfire and popping on deceleration especially through 4500RPM down. Saw some older posts here but was wondering if this is due to the aftermarket pipes and if putting on the stock ones (which I have) would solve the issue. The bike has 7000 kms (4350 miles) on it so I wouldn’t think there is something wrong with tuning/fuel (running rich or lean). I’ve had the bike less than 2 months and it did this from day one but seems more frequent and noticeable now. Any suggestion or input would help. Thanks!
 

·
Muscle Rider
Joined
·
29 Posts
It's pretty simple, if the previous owner just slapped on the slip on's and didn't get a tune put on as well that is going to cause the issue. You could solve it by going back to factory but trust me if you desire anything remotely like a HD sound you will be very disappointed.

FYI it may sound counter-intuitive but usually the way to get rid of decel popping is to add fuel during the decel curve. I have a Power Vision with autotune and widebands and that's what I learned from Fuel Moto when i saw the map being changed to add fuel during decel.
 

·
Registered
Joined
·
109 Posts
Do you have the Vance and Hines tuner as well? You can adjust one of the settings to help but it won't completely solve the problem. The info is on their website under the q&a section on which parameter to play with. Made a big difference for mine but still get the popping now and again. Even get it sometimes while at steady idle.
 

·
Registered
Joined
·
114 Posts
I recently bought a 2012 VRSCF and it came with the V&H pipes installed. I’ve been noticing a lot of backfire and popping on deceleration especially through 4500RPM down. Saw some older posts here but was wondering if this is due to the aftermarket pipes and if putting on the stock ones (which I have) would solve the issue. The bike has 7000 kms (4350 miles) on it so I wouldn’t think there is something wrong with tuning/fuel (running rich or lean). I’ve had the bike less than 2 months and it did this from day one but seems more frequent and noticeable now. Any suggestion or input would help. Thanks!
Also check for exhaust leaks.
 

·
Registered
Joined
·
125 Posts
I have the popping, but I like it on my 2014. Yep, I just slapped them on for sound and it let's people in cars know I'm there.
On my Jag F Type, you can switch from normal to the same sound your getting now with the muscle popping.
 

·
Registered
Joined
·
5 Posts
I recently bought a 2013 F with V&H slips ons. It had the back fire on decal as well. Solved it with a tune from Fuelmoto (Powervision). I also like the backfire sound but heard it's bad for the bike.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top