Harley Davidson V-Rod Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1
Got a question for those of you who wish to entertain me.

Last year (Feb. 03), I had all of my skins polished.

I started noticing what sounds like a vibration rattle coming from the aluminum airbox cover (or so it seems) during the first 5 minutes or so of riding the bike when riding it from a complete cold start.

Now the rattle vibration only occurs when I throttle up the bike either on it or off it.

I really hadn't taken the time to nail it down during my rides last year since it goes away after a few minutes after the bike warms up.

My question is this. Does anyone think that during the polishing procedure, the bond between the aluminum portion of the cover and the underside black portion has been somewhat compromised? If so, any thoughts on how to fix it? Anyone else experience this phenomenon?

Thanks

-Dipper
 

·
Color me Gone
Joined
·
27,333 Posts
Dipper it might depend on how they stripped the anodized coating off. If they dipped it in a tank then it could have broken the what appears to be urethane loose on the back side.

Have you tried running the bike without the cover to make sure it is the cover?
 

·
Registered
Joined
·
77 Posts
Discussion Starter #3
Max:

Not sure how they polished it.

Suppose I should run it without the cover when it gets warmer. That's my first priority. Hate to put the cart before the horse, but any thoughts on a remedy (that I can do), if it proves that the bond has been broken in areas?
 

·
Metal Guitarist
Joined
·
5,201 Posts
it might be one of the latches that hold the plastic air box lid on under the cover....there is one in the middle front..if it comes loose it will rattle.....same can be said for the rest of the latches aswell.....i would look into those first and make sure they are all secured.
 

·
Color me Gone
Joined
·
27,333 Posts
dipper if the bond is broken you should be able to tell without driving, the top is only bonded at three points so holding the underside you should be able to move or pull the upper skin up if the the bond has been broken. Also if they dipped the entire top the paint will look different on the bottom then a factory cover.

Max
 

·
Registered
Joined
·
77 Posts
Discussion Starter #6
Max:

Very interesting... The bottom is still black, so I guess it wasn't dipped.

'Just tried to pull it apart and it won't budge... Some food for thought...

Looks like I have to look elsewhere... 'Will test it out when it gets warmer.

Thanks for the great info and quick response.

-Dipper
 
1 - 6 of 6 Posts
Top