Harley Davidson V-Rod Forum banner

1 - 20 of 132 Posts

·
Premium Member
Joined
·
836 Posts
Discussion Starter #1
Just was wondering how many people out there were having problems with them. It if you have had problems what do you have done to your bike? I have stage 2 cams, and it seems to be a common problem with these cams.
Anyone else?
 

·
brett
Joined
·
9,338 Posts
a few have brocken including destroyer ones , the butterflys get a crack in them at the shaft where the screws go ,i think from memory ,if thats what jaben is talking about
 

·
Premium Member
Joined
·
836 Posts
Discussion Starter #4
Yes, that is what I was talking about. Sorry, I should pay more attention to what I am writing.
Who has broken the shaft that the butterflies mount too. I have now broken two of them. They both broke right at the mounting screw. The shaft cracks all the way through. I am going to take a few pics of the current one, and try and post them.
 

·
Registered
Joined
·
2,103 Posts
i wish you guys would stop scaring me... i would be sick if a screw out of a throttle blade or part of a shaft went through our motor...gonna be checking ours closely..
 

·
Premium Member
Joined
·
836 Posts
Discussion Starter #7
Not trying to scare anyone, just getting info out that things are breaking. It seems like it is mostly people with the stage 2 cams. I haven't really heard of any other setup breaking like that. That is why I asked the original question.
 

·
Premium Member
Joined
·
5,718 Posts
Mine broke and I have Megacycle cams that are outrageously huge (not very streetable IMHO) that I plan on replacing with Stage II cams shortly. Mine has been back together for a while now though with no more issues.
 

·
Registered
Joined
·
2,103 Posts
we have run ours for quite a while with a lot more radical cams than stage 2.. i have seen what a screw can do in a cyl.. i have too much time in our cyl heads and pistons to not cry like a baby if it happened to us..
 

·
Premium Member
Joined
·
836 Posts
Discussion Starter #10
Well unfortunately i have broke two of them. Each time it cracked both posts completely through.
 

·
Premium Member
Joined
·
7,727 Posts
IF the cams were to have anything to do with breaking throttle bodies I would bet it is a harmonics deal causing the plates to flutter causing fatigue of the metal.
 

·
Premium Member
Joined
·
5,718 Posts
I believe mine was a tuning issue. I had a lot of decel popping going on and heard it through the intake a few times and then the blade shaft was broken.
 

·
Bone Stock B Model
Joined
·
8,639 Posts
Not trying to scare anyone, just getting info out that things are breaking. It seems like it is mostly people with the stage 2 cams. I haven't really heard of any other setup breaking like that. That is why I asked the original question.
I would love for someone to explain to me how a stage 2 cam can brake a throttle body shaft in half...

Harmonics if that being the case my shit would have blown to bits about 2 years ago. I dont know anyone's bike that has more decel pop than mine.
 

·
Hi... I'm Big Will
Joined
·
1,087 Posts
i wish you guys would stop scaring me... i would be sick if a screw out of a throttle blade or part of a shaft went through our motor...gonna be checking ours closely..
Been there, done that and got the T-Shirt... it sucks ass. I did get my heads ported, polished and oversize valves put in while it was apart though. :D
 

·
loud & low & solo
Joined
·
634 Posts
i too have experienced the broken 58mm TB's issue and i am also running the stage 2 cams and it was running amazing with NO POPS OR COUGHS... had about 600 miles on them and found they were broke.

they are breaking right across the screw holes... i fully believe that if the shafts were made with NO SCREW HOLES and just TIG weld the butterflies right to the shaft there will be an end to the broken shafts... i know fitzgerald 58's already come with the screw tacked right to the shaft... but i fully believe that if the shaft had no holes in them and just plug weld the butterflies right to the shaft from the top that it would have no where to break... ive been welding for 9 years now along with alot of tig work to back me.
 

·
Ron Cooper
Joined
·
1,809 Posts
I believe that a stronger shaft would fix your problem. I have some Ti that I could make a few shafts out of if anyone is interested.
 

·
Dances with Rain!
Joined
·
3,713 Posts
I believe that a stronger shaft would fix your problem. I have some Ti that I could make a few shafts out of if anyone is interested.
Ron,
I am interested in doing what you are saying as I just experienced my first TB failure with 1500 miles on my 1302. I have the 58mmTB and Stage II SCE Cams.
I might do what Big Will suggested and put a stock TB back on.
Looking for suggestions.

Jim
 

·
Ron Cooper
Joined
·
1,809 Posts
I have spoke with Will on this matter. If you have a rod or if anyone has a rod and they could send it to me I have a gun that I can analyze the material of the shaft and see exactly what it is made of and then go from there. I do believe a stronger shaft and hardware will solve this problem.
 

·
Premium Member
Joined
·
836 Posts
Discussion Starter #20
Well i am in toledo ohio with two broken shafts. I could send you the whole tb if it means there could be a permanent fix.
 
1 - 20 of 132 Posts
Top