Harley Davidson V-Rod Forum banner

21 - 38 of 38 Posts

·
Registered
Joined
·
14 Posts
My 2012 NRS was equipped by the dealer with K&N filter and V&H Black Widows. Also paid $100 for "stage 1 download". Ran like crap, used my SEPRT (that I had to buy for the download) and installed the"mytune" map off this forum. Couldn't be happier, runs like a different bike (runs GREAT!).
 

·
Registered
Joined
·
24 Posts
My '13 F had same issues with that with the slip-ons and K&N. After a few months of back and forth I took the map they gave with the basic first changes that fixed the 4500 area pop and did the rest myself and runs like a dream now. It ended up being like 5-6 values that were the issue. Set them to zero then added fuel to them until it started again then backed them off one at a time. If I remember right they told me the first values are for fuel up to 25 i think and for every seven points you add is 1 afr point.
 

·
Registered
Joined
·
24 Posts
This is what I have for values from 1-20 some are changed some are standard after 20 it is all base values for map 4690.

6,8,4,4,12,7,6,23,15,20,23,27,7,0,25,2,15,23,17,2

This was working with V&H and my own tinkering found that modes 10-13 where the issue after all the other values they gave me to get rid of other issues that their values had fixed. I hope it helps you guys out, have ran it in these settings for the last few month of riding last year with no issues at all. Then Minnesota happened again and the bike is sitting.
 

·
Registered
Joined
·
16 Posts
I also have a issue between 3000 - 4000 rpm with Fuel Pak and V&H 2-1 Comp. This is making my rush hour ride home a real P.I.A. I can maintain 3000 and go up to 4000 without any problems but if try to back off just a hair it starts chugging and bucking.
 

·
Registered
Joined
·
16 Posts
My issues my have been resolved just by going topples, I won't know for sure until I get off work Tuesday morning.:notworth:
 

·
Registered
Joined
·
10 Posts
Do they make the SESPT for NRS anymore? I have a 13 DX and want to go this route but can't seem to find it. With the Black Widow slip ons and no filter my bike is red lining at 6k so Iam assuming I need a tuner....
 

·
Registered
Joined
·
2,907 Posts
???? No filter??? Why? Gonna cause nothing but issues. What do you mean red lining at 6k. Does it sound like a rev limiter at 6k? Something not right
 

·
Registered
Joined
·
10 Posts
Yes I hit the rev limiter at 6k Ill get the filter eventually just thought that if I changed the filter, I HAD to get the fuel pack or power commander.
 

·
Registered
Joined
·
9 Posts
Has anyone tweeked the fuelpak 4690 tune for a topless mod with k&n filter and v&h slip ons that would work for a 2013 muscle.
 

·
Registered
Joined
·
28 Posts
I have a 2010 Muscle. V&Hyundai slip ons. Topless. Getting some back fire at 4 to 5 rpm while cruising. Any ideas what settings to change?
 

·
Registered
Joined
·
736 Posts
Fuel pack

Has anyone used a V&H FuelPak on a 2012 VRSCDX?

I installed a set Vance and Hines Widow slip-ons with the usual K&N filter along with a new FuelPak.

I can definitely tell the difference in performance, specially at higher rpms. But the bike appears to be running lean at light throttle openings, between 3k - 4k rpm....it misfires a lot.

I double checked the installation/wires/fuel map numbers...everything is correct.

I called V&H and they asked me to modify three modes of the original fuel map that I got from their website. It helped quite a bit, but the bikes still missfires between 3-4k rpm. So I called them back and we modified the fuel map one more time, but it is still doing the same thing.

Just wondering if anybody else was having the same issues.

I am new to the Harley Davidson world..love my v rod.

Thanks!
Hey Man send it back, Been through it all w/them. They dont have a fix.I was trying different maps for a month. And it will take 30 days for them to get you a refund. I have already posted on this. I have exactly the same set up. I finally removed the cursed thing and the k&n filter. Filter just sitting in garage for now. And one other thing, when you decide to remove it, the bike will stall several times until it apparently learns again. scary sh?? Again send it back, even if you get to run ok, you dont really know how the engine is doing, rich lean etc.Only way is to put it on a dyno. V&h is supposed to have a better one out there,I gave up.
 

·
Registered
Joined
·
4,173 Posts
For one of these bikes, the FuelPak is like pissing in the wind. It will never accomplish any form of a decent tune.
Ron
 

·
Registered
Joined
·
62 Posts
I have the exact same bike as yourself, here in Malaysia. Last week, prior to Chinese New Year, I had the bike modified to run topless and installed the Power Commander 5. I then had it dyno tuned (you can see the chart under the post V-ROD EFI / Dyno chart for 2012 Nightrod Special - 120 hp to rear wheel). As I have only ridden it from the shop to home, in traffic, prior to going to my wife's village for the CNY celebration, I cannot definitively say how it runs, but I will say that the throttle response is smoother and re-mapping each cylinder has the front cylinder running much cooler. I think that with the Vance and Hines short pipes these bikes will always 'pop and snap' when decelerating/getting off the throttle - misfiring is another issue.
 

·
Registered
Joined
·
62 Posts
Backfiring etc...after topless mod and Power Commander5 installation

As mentioned previously, I had the PC5 installed on my bike and the topless modification done prior to dyno tuning the bike (as follows):

2012 Nightrod Anniversary Special
Vance and Hines 2-into-1 exhaust
Stage 1 modification to the air filter
Changed the front sprocket from 30T to 28T (was the int'l version)
Power Commander 5 installed
Topless modification performed

This yielded 120.18 HP @ 8720 rpm & 110.78 Nm @ 6550 rpm at the rear wheel.

I took the bike out for an 11-1/2 hour run to Genting Highlands, Malaysia yesterday, and noticed the following:

Runs cooler
Smoother throttle response
More aggressive acceleration
Much less 'popping & snapping' when letting off the throttle
Different sound (good or bad? Depends on the owner I suppose)
 

·
Registered
Joined
·
1 Posts
This is what I have for values from 1-20 some are changed some are standard after 20 it is all base values for map 4690.

6,8,4,4,12,7,6,23,15,20,23,27,7,0,25,2,15,23,17,2

This was working with V&H and my own tinkering found that modes 10-13 where the issue after all the other values they gave me to get rid of other issues that their values had fixed. I hope it helps you guys out, have ran it in these settings for the last few month of riding last year with no issues at all. Then Minnesota happened again and the bike is sitting.
Do you think this will work on my 13 dx?
 
21 - 38 of 38 Posts
Top