Harley Davidson V-Rod Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I bought a 2005 Harley Davidson v-rod 2 months ago and the original owner switched out the ignition to a simple turn knob switch with no key fob. I switched out the light bulbs in the turn signals and now my bike won’t start. When I turn the bike on it shows a solid red key light. Looking for suggestions on how I can fix this or figure out what the problem is
 

·
Premium Member
2004 vrsca
Joined
·
73 Posts
My 04 has it on ever since I changed the front and rear turn signals. The stock turn signal/bulbs have a specific resistance that the system will recognize. Did you install any aftermarket turns? For example the kuryakyn turn signals come with resistances that you need to install for avoiding this issue
 

·
Registered
Joined
·
460 Posts
To check your HFSM/TSSM/TSM configuration:
  1. Set engine stop switch to OFF
  2. Cycle IGN switch: ON-OFF-ON-OFF-ON
  3. Press left turn signal button 2 times and wait for confirmation turn signal flashes:
One flash: TSM (no security)
Two flashes: Japan/Korean security configuration
Three flashes: Domestic security configurationIf you see more than one flash then I have no idea how your system is not arming or how it starts without a fob present or by entering a PIN to disarm it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Turn signal module is also the security module (TSSM), are turn signals working now? Is there a blown fuse? My 2006 will start and run without the FOB present.........
The turn signals are not working. When I turn the ignition on the headlight works and the gauges move but then when I flip the run switch the red solid key symbol pops up.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
Just exactly what did you do to the bulbs? new bulbs? new LED direct plug ins? wired in new lights? Try undoing what you did? Check all fuses .........
New LED direct plug ins and changed signal cap covers. I’ve undone everything and put original bulbs back in with no change. I thought it was my battery but I’ve hooked it up to a jump starter and it doesn’t even try to roll over or make a clicking sound.
 

·
Registered
Joined
·
460 Posts
I thought it was my battery but I’ve hooked it up to a jump starter and it doesn’t even try to roll over or make a clicking sound.
it won't if security system has it locked out. Security system on newer vehicles actually tells the ECM/BCM to engage the starter......... turning the key just sends a signal to the security module. Check all your fuses under the right front cover?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #15 ·
I thought I had added descriptions to the pictures. I have checked all fuses but don’t know how I go about retrieving codes concerning red key. I have contacted a local Harley dealership and they are recommending replacing the factory security system.
 

·
Registered
Joined
·
460 Posts

·
HAS_VROD
Joined
·
25 Posts
A simple volt/ohm meter should help here. Check both sides of the fuse socket to ensure it is passing power. Check power (volts) to the lights when you turn on the blinker switch. And, start this with the key/switch off…and any fuse not passing power, check it again with the key switch on to better understand what is hot all the time and with the key on. Document what you find.

Any place where you have power but something is not working (like your blinkers), check the resistance (ohms) and document those. All four (front left/right, rear left/right) should be similar.

If all fuses are passing on power (with key on), use your info on power to lights to understand where some of the problem is. Use the check procedure on your security…but most V-Rods before 2007 don’t need a key fob as those fobs are just wireless security on/off (as is my 2006 V-Rod…but 2007 Softail needs the fob present).
 
1 - 18 of 18 Posts
Top