Harley Davidson V-Rod Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey Guys,

I have a problem with my 2003 anniversary v-rod stalling when hot after riding for about 30 minutes.

The engine runs well and has no issue while it's cold. When it gets hot it suddenly stalls after I pull to a stop in traffic lights etc. The engine stalls after being idle for a few seconds and I can't fire it back up until I close the switch. Ones I open back the switch the engine fires up and rides nicely until the issue happens again.


These are the things I've checked and done:

1. I have went to the dealer and they didn't find any issue.
2. I have checked the battery and ground terminals and they are all connected correctly and tightly.
3. I placed a new MAP sensor and IAC sensor
4. I have checked all the screws in the butterflies and throttle linkage and the throttle position sensor.
5. I have checked for air leaks and couldn't find any.
6. Sometimes the P0505 error will appear and immediately disappear.
7. I have a VANCE & HINES FUELPAK, supertramp exhaust and high flow air filter.

Any ideas what could be the problem?
 

·
Registered
Joined
·
5,229 Posts
Hey Guys,

I have a problem with my 2003 anniversary v-rod stalling when hot after riding for about 30 minutes.

The engine runs well and has no issue while it's cold. When it gets hot it suddenly stalls after I pull to a stop in traffic lights etc. The engine stalls after being idle for a few seconds and I can't fire it back up until I close the switch. Ones I open back the switch the engine fires up and rides nicely until the issue happens again.


These are the things I've checked and done:

1. I have went to the dealer and they didn't find any issue.
2. I have checked the battery and ground terminals and they are all connected correctly and tightly.
3. I placed a new MAP sensor and IAC sensor
4. I have checked all the screws in the butterflies and throttle linkage and the throttle position sensor.
5. I have checked for air leaks and couldn't find any.
6. Sometimes the P0505 error will appear and immediately disappear.
7. I have a VANCE & HINES FUELPAK, supertramp exhaust and high flow air filter.

Any ideas what could be the problem?
Oddly enough the electrical manual makes no mention of this but I've run into this twice on other harleys with IAC . If you are coming to a stop and the engine idle degrades to the point it quits and then with a key off and back on it' idles normally and considering you've done all the normal IAC swap and wiring checks, look into replacing the VSS sensor. It controls IAC steps related to vehicle speed. Since the IAC went out of range, this could be why you are seeing the code even though the fault is from another sensor.
A secondary possible is the IAT goe out of range when hot, altering the fueling to a none friendly idle mixture but not far out enough to throw it's own code. My vote would be the VSS sensor.
Ron
 
1 - 2 of 2 Posts
Top