Harley Davidson V-Rod Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi all, new to the sight.

I have a 2002 VROD that as of Friday the instrument cluster went dead on me. the only thing that works are the back light and the turn signals. This happened to me a couple of months back and I found a blown fuse. This time, the fuse is OK. Any suggestions?

Thanks in advance.
 

·
Jarhead
Joined
·
598 Posts
Did you ride in rain or recently wash the bike?
 

·
Premium Member
Joined
·
6,248 Posts
... I have a 2002 VROD that as of Friday the instrument cluster went dead on me. the only thing that works are the back light and the turn signals. This happened to me a couple of months back and I found a blown fuse. This time, the fuse is OK. Any suggestions? ...
From what you describe the likely problem is the IGNITION fuse / circuit. This is a gray wire that connects to pin #6 in the 12-conductor connector at the back of the IM. You should check this connector to make sure it’s seated correctly and all contacts are good.

I’d also check the IM ground wire on pin #5 of the IM connector. This is a black wire that connects to the rear cylinder cam cover shown in this picture as item "8" = “GND 1”. Just because the fuse looks good it could be bad so double check those also and the wires that connect these to the IM. The fuses and wires for the IM are:
IGNITION fuse / gray wire / connects to pin #6
ACCY fuse / orange with white stripe wire / connects to pin #12​
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
Thanks for the responses. I checked every fuse visually and they all looked good. I pulled the connector and as described there was no power. Went back to the fuse box again and pulled the fuse, this time I checked it with a meter. the impedance was very high around 12M ohms, essentially open. Replaced the fuse and all is well.

Does anyone have a wiring diagram available? I would like to see where else the power source goes to see if there is any contact being made with the frame. I cant imagine anything on the spedo printed circuit board drawing enough current to blow a 15A fuse.
 

·
Premium Member
Joined
·
6,248 Posts
... Does anyone have a wiring diagram available? I would like to see where else the power source goes to see if there is any contact being made with the frame. ...
Schematics are included with the Service Manual (99501-02A for your year) and with the Electrical Diagnostic Manual (99499-02).

Here’s a partial schematic I drew that shows the Starting Circuit. This shows the IGNITION fuse circuit connections but the ACCY fuse circuit in this drawing is not complete. This O/W wire also connects to the brake light switches and to the turn signal switches as well as to the rear tail lamp connector and a connector up front used for a “City Lamp” on the overseas models.
 
1 - 5 of 5 Posts
Top