Harley Davidson V-Rod Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
343 Posts
Discussion Starter #1
Guy's I have a 15 nrs and it has a intermittently over heating problem. It doesn't happen all the time and it's been when I'm hammering on it both times. It's not losing any coolant and the triple sprocket bolt has been checked. plus a new rad cap. I ordered a new thermostat and gasket, but just wanted to check here for suggestions.
 

·
Registered
Joined
·
701 Posts
over heating

Guy's I have a 15 nrs and it has a intermittently over heating problem. It doesn't happen all the time and it's been when I'm hammering on it both times. It's not losing any coolant and the triple sprocket bolt has been checked. plus a new rad cap. I ordered a new thermostat and gasket, but just wanted to check here for suggestions.
Be sure and check that both fans are running. And check when and at what temp they come on. Make sure radiator is clean(wash it out)and no debris is caught in the shroud. I am assuming you dont have screens in shroud openings. And if you ride hard in TX heat and get stuck in traffic, you might get that light to come on at times.You need to get moving as soon as possible to get air flow. I have had this happen before on a certain expressway. I have found if the ground temp gets very hot, heat rises and guess where your radiator gets its air, and w/ the fans running drawing that hot air in also. I also had those screens, and removing them helped a lot. Dont rev engine rpms as much in traffic, let it pull in the tall gears as much as possible w/o lugging. You may need a thermostat MAYBE, I have a 2012 and thermostat is original at 85k. You should have a temp gauge installed.These engines get pretty hot. You may try a coolant additive ICE I believe its called. I put some in before. Cant say if it did anything or very little. I have not had the light come on anymore since I relocated. Good coolant and a clean air filter.And finally do you have an aftermarket tune piggyback module etc. Because it can also be a bad tune, if pipes are installed w/o a tune.
 

·
Registered
Joined
·
343 Posts
Discussion Starter #3
Thanks for the reply. I have tried all of the above, but I have been fighting with this tuner. My bike has been running lean. The thing is that my 13 nrs never did this and this bike does it once a summer and may not do it again until next year.
 

·
Cabeca de Ferro
Joined
·
411 Posts
Check the water pump too.I have seen some cases of a lot of rust due to the use of ordinary water rather than demineralized water.
 

·
Registered
Joined
·
294 Posts
I believe on all the new Models when you put the maxi fuse in the fans should run up strong for a few seconds then off.
If Thermostat,Fans etc seems good -
Just if maybe a blockage: I've had 3 bikes, all liquid cooled, so I get nutz about flushing

- Did you pull the drain plug on the front cylinder
and the upper vent hole under the airbox when draining?

I first flushed my 06 D when I got it with 2 cycles of distilled water and Vinegar heated up and bubbling, then flushed again with Dist Water Vinegar may have been a mistake in hindsight but I've always done that.
Then filled with the HD Coolant -

This spring (2 years later)
Drained it again. opened both drains and the air bleed screw up top
Poured 2 gallons of Dist water through and stuck a hose in the fill and blew on it like a bastard....
Filled with Peak Global Lifetime $15.00 (its' the same stuff) - per this site.
Mixed about 3 parts coolant to 1 part water wetter.
Subjective results is it is running * a little cooler Fans kick off quicker. dont come on as often.

After flush/fill It always burps some air up overnite and needs a to be finally topped off he next day on mine.
Maybe you Got some air in the system?

* If you cant find a problem with the system -
* knight rod rob referred to Ice - probably "Engine Ice" - Good stuff
So is water wetter -

If stored for winter in a cold climates full strength or a mix may freeze in there more quickly that full strength coolant.
 

·
Registered
Joined
·
976 Posts
If you have a tuner . Adjust the fan to turn at a lower temperature then stock setting.
 

·
Registered
Joined
·
343 Posts
Discussion Starter #9
Guy's I found the problem, it was the black powder coat that Harley uses for the filler neck had gotten into the system.
 
1 - 9 of 9 Posts
Top