Harley Davidson V-Rod Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter #1
I tried the search feature. I am not sure what you would call the issue. Whenever I throttle hard, I get kind of a bogging. But if I ease up on the throttle it will go with no issues. I have replaced spark plugs, not that the old ones were bad. But since I had her apart checking on things I figured why not. I cannot find any vacuum leaks. Any help or guidance would be great.

Thanks
 

·
The Hawk
Joined
·
3,772 Posts
Check the fuel pressure, you can borrow a gauge from most auto parts stores, it takes the same as for a Chevy. The Schrader valve is below the rear throttle body on the right side.

Sent from my Moto Z (2) using Tapatalk
 

·
Registered
Joined
·
72 Posts
Discussion Starter #3
Check the fuel pressure, you can borrow a gauge from most auto parts stores, it takes the same as for a Chevy. The Schrader valve is below the rear throttle body on the right side.

Sent from my Moto Z (2) using Tapatalk
55lbs of pressure. If I am just revving in neutral no issues. It's just when I am moving.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #5
Ok so searched for hard acceleration bogging. A few hits. Some say a tune, some say map sensor. I am stock fully stock except the V&H exhaust it came with. I did go ahead and change the fuel pump today as well with a Quantum. But no luck. I do not have any aftermarket piggy back ecu's either. Wouldn't a bad map sensor throw a CEL
 

·
Registered
Joined
·
680 Posts
Bogging

I tried the search feature. I am not sure what you would call the issue. Whenever I throttle hard, I get kind of a bogging. But if I ease up on the throttle it will go with no issues. I have replaced spark plugs, not that the old ones were bad. But since I had her apart checking on things I figured why not. I cannot find any vacuum leaks. Any help or guidance would be great.

Thanks
Since you have aftermarket exhaust. I feel you should do a stage one program. Which may have already done when exhaust was added. But its worth a check to find out.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #7
I just ordered Dynojet Power Vision. So hopefully i can get some maps and see what I can do.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #8
Power Vision hooked up, tried 3 different tunes, it cleaned it up a bit. But instead of bogging down, then having to let off and slowly accelerate, it just bogs but keeps going.
 

·
Registered
Joined
·
3,980 Posts
Power Vision hooked up, tried 3 different tunes, it cleaned it up a bit. But instead of bogging down, then having to let off and slowly accelerate, it just bogs but keeps going.
Since you now have the power to reduce guess work, run a log. I, we, can view it and see if all sensors are functioning within spec. Also, any cal you load will need to be dialed in, however, I've never seen any of them cause bog . If you want, send me the log to view sensors. Make about 15-30 minute log. I will pm my email.
Ron
 

·
Registered
Joined
·
72 Posts
Discussion Starter #12
Did you also clear fuel trims?

I did. But I have since changed exhaust and have run like 20 autotune runs and its not getting better. I have called a few places in Houston to see if I can get a tune, but they wont do it as they have told me the power vision is not carb.
 

·
2012 VRSCDX
Joined
·
6 Posts
I don't follow the "Power Vision is not carb" statement. Look through your past DTC's and see what comes up. As a test, unplug the MAP sensor on the airbox and start the bike just to be sure you get a reliable code for that. I chased my poor running issues for a while before finally just pulling the trigger and doing a Power Vision. Turns out the PO had had a shit tune flashed to the ECM and it just made the bike run bad in the 2000-3500range. Fuel map from Fuel Moto and runs like a whole new bike.
 

·
Registered
Joined
·
72 Posts
Discussion Starter #14
Not carb exempt I believe it was they say. Not street legal. So they won’t touch it.


Sent from my iPhone using Tapatalk
 

·
2012 VRSCDX
Joined
·
6 Posts
Shops are stupid. Your poorly running bike is worse for the environment and they should want to help fix it. Where did you get your tune from?
 

·
Registered
Joined
·
72 Posts
Discussion Starter #16
Shops are stupid. Your poorly running bike is worse for the environment and they should want to help fix it. Where did you get your tune from?


It’s the tune that came with the PV from fuelmoto. I had it going well with my V&H but then changed to the Akrapovik and just can’t get it any better than where it started.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
237 Posts
rbabos: dude I hope you never leave this forum. You are awesome.

If rbabos can’t find anything wrong with your tune then to me it sounds like a fuel issue.
How many miles do you have?
I saw a real dirty fuel filter on a rod with only 8k miles.

Did you bike run like this before the mods or after?

Have you checked the negative terminal and leads on the battery?
 

·
Registered
Joined
·
72 Posts
Discussion Starter #18
rbabos: dude I hope you never leave this forum. You are awesome.

If rbabos can’t find anything wrong with your tune then to me it sounds like a fuel issue.
How many miles do you have?
I saw a real dirty fuel filter on a rod with only 8k miles.

Did you bike run like this before the mods or after?

Have you checked the negative terminal and leads on the battery?
Yes Rbabos helped me a good bit with my original tuning. But after i changed exhaust I did not want to bother anyone anymore. I was just going to have a shop do it.


Buttt. As long as i am just cruising and not getting on it. It does fine.
 
1 - 18 of 18 Posts
Top