Harley Davidson V-Rod Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Ok need some help stumped badly been going on for about year now my fuel tuner shorted out and ended up melting my main harness so I put a new harness on it new starter new starter solenoid new crank sensor new voltage regulator and new battery and still when I push start button just get a click motor doesn't turn over at all any help would be appreciated cause I'm at a loss with this and been long ready to get it back in the wind thanks in advance
 

·
Tie One On
Joined
·
1,647 Posts
does the motor turn 360 degrees by hand??good to rule other things out like a seized up motor.
verify all grounds.
verify full charge on battery
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Verified charged battery and checked all grounds again when I push button the starter wire and starter get extremely hot how do u turn motor over manually I also meant to add had buddy look it over one night and left airbox cover off and it rained that night so water got into the throttle body
 

·
Registered
Joined
·
2,246 Posts
Verified charged battery and checked all grounds again when I push button the starter wire and starter get extremely hot how do u turn motor over manually I also meant to add had buddy look it over one night and left airbox cover off and it rained that night so water got into the throttle body
If you got enough water down there motor could be hydrauliced. Take the spark plugs out and see if it turns then. Take the small cover (2 bolts) off the left hand side of the engine to rotate manually with socket. Remember if you try rotating by hand, counter clockwise only or you might invite more problems. Good luck.
 

·
VRSC est -03
Joined
·
3,403 Posts
Verified charged battery and checked all grounds again when I push button the starter wire and starter get extremely hot how do u turn motor over manually I also meant to add had buddy look it over one night and left airbox cover off and it rained that night so water got into the throttle body
Sounds like too much resistance.. Ground wire located rear end oilpan engine-frame ok?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #8 ·
So coming up with 1481 which I know is fan relay and 0384 crank sensor but it's a new sensor and I put meter on wires and try to start don't show any voltage would that mean my ecm is junk now also
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top