Constant Radiator Fans Running - 1130cc.com: The #1 Harley Davidson V-Rod Forum
» Sponsors
Go Back   1130cc.com: The #1 Harley Davidson V-Rod Forum > V-ROD Discussions > V-ROD Technical
New User? Register - Forgot Password

Reply
 
Thread Tools Display Modes
Old 12-26-2019, 11:27 PM   #1
Jemragz
Registered Full
 
Join Date: Dec 2019
Posts: 2
Feedback Score: 0 reviews
Question Constant Radiator Fans Running

Hi fellow riders I'm new to forum but have gained a wealth of information from browsing forum as a non member in the past. I was out riding and an hour into ride bike intermittently was dropping rear cylinder. Further into ride it become more frequent and longer so i pulled over and numerous codes appeared. Codes as followed what I can remember were etc sensor, relay, rear coil and injector. A buddy with me let me try his relay which made no difference we also swapped the rear coil and also didn't change anything. Bike all of a sudden came right after putting my parts back in. Headed for home and it shut off rear cylinder the whole way home. Got in garage and started to pull bike to pieces. I swapped all relays between the system, starter and fans. After that the bike started and ran like normal except fans kept running. I then remembered not hearing any fans throughout entire ride. I then checked continuity from fan relay to ECM pin two and there was no evidence of shorting to ground. I pulled ECM and then fans stopped. I have checked all earths and all seem tight. Only way to stop fans is to pull relay. Am I up for a ECM or is there something I have missed. The only other thing I can think of is maybe the etc sensor is tricking ECM to ground the number two pin wire. Tried to test etc but is so tight in there I have just put all plugs back together. Cheers sorry for the novel. I am riding a 2017 Night Rod Special.

Last edited by Jemragz; 12-26-2019 at 11:40 PM. Reason: Adding more info
Jemragz is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-27-2019, 11:32 AM   #2
rbabos
Registered User
 
Join Date: Jul 2012
Location: Woodstock Ontario Canada
Posts: 3,706
Feedback Score: 1 reviews
Quote:
Originally Posted by Jemragz View Post
Hi fellow riders I'm new to forum but have gained a wealth of information from browsing forum as a non member in the past. I was out riding and an hour into ride bike intermittently was dropping rear cylinder. Further into ride it become more frequent and longer so i pulled over and numerous codes appeared. Codes as followed what I can remember were etc sensor, relay, rear coil and injector. A buddy with me let me try his relay which made no difference we also swapped the rear coil and also didn't change anything. Bike all of a sudden came right after putting my parts back in. Headed for home and it shut off rear cylinder the whole way home. Got in garage and started to pull bike to pieces. I swapped all relays between the system, starter and fans. After that the bike started and ran like normal except fans kept running. I then remembered not hearing any fans throughout entire ride. I then checked continuity from fan relay to ECM pin two and there was no evidence of shorting to ground. I pulled ECM and then fans stopped. I have checked all earths and all seem tight. Only way to stop fans is to pull relay. Am I up for a ECM or is there something I have missed. The only other thing I can think of is maybe the etc sensor is tricking ECM to ground the number two pin wire. Tried to test etc but is so tight in there I have just put all plugs back together. Cheers sorry for the novel. I am riding a 2017 Night Rod Special.
Do you have a piggy back tuner on it or just stock ECM inputs? Temp sensor supplies the resistance level to trigger the ground from the ECM. Any possible short as in a direct ground happening pre ECM?
Ron
rbabos is online now   Reply With Quote
Old 12-27-2019, 05:45 PM   #3
Jemragz
Registered Full
 
Join Date: Dec 2019
Posts: 2
Feedback Score: 0 reviews
Thanks Ron. I have only added slip ons for exhaust and running hi flow air filter topless and gave it a dyno tune using the screaming eagle dongle. I will double check for shorts but wiring seems tight and clean. Bike has only 6000 km on it.
Jemragz is offline   Reply With Quote
 
Old 12-28-2019, 03:35 PM   #4
Elgavilan
The Hawk
 
Elgavilan's Avatar
 
Join Date: Sep 2004
Location: Yuma, Arizona
Posts: 3,752
Images: 21
Feedback Score: 16 reviews
Clear all the codes then run it again and see if it sets any codes. When you pull the master fuse and then reinsert it the fans will run for a bit.

Sent from my LM-G820 using Tapatalk
__________________
It's not how fast you go, it's how fast you get there!
Elgavilan is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 02:53 PM.



Powered by vBulletin® Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Motorcycle News, Videos and Reviews
Honda Grom Forum strong>Kawasaki Z125 Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Honda Africa Twin Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum Ducati 959 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum
Yamaha Motorcycles Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum
BMW Scrambler Forum Ducati Scrambler Forum