battery not charging - 1130cc.com: The #1 Harley Davidson V-Rod Forum
» Sponsors
Go Back   1130cc.com: The #1 Harley Davidson V-Rod Forum > V-ROD Discussions > V-ROD Mechanical
New User? Register - Forgot Password

Reply
 
Thread Tools Display Modes
Old 05-19-2017, 12:56 AM   #1
porsche2576
Premium Member
 
Join Date: May 2017
Location: london
Posts: 2
Feedback Score: 0 reviews
battery not charging

just bought a 2004 v rod
went to start after 3 days and battery has not enough power to turn engine
bought a optimate 4 and connected to battery tender
left all night but has not charged battery
when i connect the charger to bike it seem that's charger is not charging battery
only the green power light on left of optimax is coming on ,no other lights work on charger
porsche2576 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-19-2017, 01:37 AM   #2
Knut J
VRSC est -03
 
Knut J's Avatar
 
Join Date: Apr 2007
Location: Arctic Circle, Norway
Posts: 1,486
Feedback Score: 0 reviews
Battery prolly dead. Age? Brand?
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
WILL RACE FOR FOOD!
Knut J is online now   Reply With Quote
Old 06-12-2017, 07:29 PM   #3
LynnKiffer
Dozer
 
Join Date: Jun 2017
Location: Virginia
Posts: 6
Feedback Score: 0 reviews
Question

I have the same issue except the battery charger says its charged but it isnt, I go through a battery a year from something drawing on the battery....I have no extra draw, I took off the alarm system hoping that was the draw but it didnt change anything....I have to keep it on a charger at all times when it isnt being used....Any suggestions?? Did you figure anything out for your issue?
LynnKiffer is offline   Reply With Quote
 
Old 06-13-2017, 11:53 AM   #4
porsche2576
Premium Member
 
Join Date: May 2017
Location: london
Posts: 2
Feedback Score: 0 reviews
put a new battery but it was still loosing the charge
took the charger back to shop and they showed it was working ok
shop told me to check the lead from bike that connects to charger.there is a fuse on the lead and the fuse had blown
replaced fuse and everything is good
when i bought the v rod the shop said to keep bike on charger when not being used as the alarm drains the battery
with the bike on charger it always starts first go
even when not used for few days
porsche2576 is offline   Reply With Quote
Old 06-13-2017, 12:51 PM   #5
rbabos
Registered Full
 
Join Date: Jul 2012
Location: Woodstock Ontario Canada
Posts: 1,963
Feedback Score: 0 reviews
Quote:
Originally Posted by LynnKiffer View Post
I have the same issue except the battery charger says its charged but it isnt, I go through a battery a year from something drawing on the battery....I have no extra draw, I took off the alarm system hoping that was the draw but it didnt change anything....I have to keep it on a charger at all times when it isnt being used....Any suggestions?? Did you figure anything out for your issue?
You need to do a parasitic draw test on the whole electrical system. Could be as simple as failing diodes in the voltage regulator.
Ron
rbabos is offline   Reply With Quote
Old 06-13-2017, 06:05 PM   #6
LynnKiffer
Dozer
 
Join Date: Jun 2017
Location: Virginia
Posts: 6
Feedback Score: 0 reviews
Arrow

Thanks! I'll look into that!
LynnKiffer is offline   Reply With Quote
Old 06-15-2017, 07:36 AM   #7
inultus
Registered Full
 
inultus's Avatar
 
Join Date: Jun 2017
Location: Lansing
Posts: 20
Feedback Score: 0 reviews
Easiest and first thing to do is check the voltage on the battery with a voltmeter. Do this without the charger plugged in, then do it again with the charger plugged in, it should change.

BTW, I think the manual says the battery needs to register at least 12.6volts (without being on charger) to be considered good.
inultus is offline   Reply With Quote
Old 06-20-2017, 02:52 PM   #8
mikes06rod
Premium Member
 
mikes06rod's Avatar
 
Join Date: May 2011
Location: Jonestown, PA
Posts: 529
Feedback Score: 1 reviews
Like rbabos noted , it could be the voltage regulator , I had this problem . My bike doesn't have the alarm system . If I rode it about every week , it would start OK . If it was rainy and I only rode it every-other week , it would struggle to start . If I didn't ride it for 3 weeks , it wouldn't start . I replaced the voltage regulator , and this condition went away , without using a battery tender in-between rides .
Mike
mikes06rod is online now   Reply With Quote
Old 06-20-2017, 05:34 PM   #9
LynnKiffer
Dozer
 
Join Date: Jun 2017
Location: Virginia
Posts: 6
Feedback Score: 0 reviews
Talking

Thanks yall! I really appreciate the suggestions...Stay tuned I'm gonna try each one...and see what I come up with.
Again,
THANK YOU!
yall are way nicer than the jeep forums.
LynnKiffer is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 02:13 PM.



Powered by vBulletin® Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Motorcycle News, Videos and Reviews
Honda Grom Forum strong>Kawasaki Z125 Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Honda Africa Twin Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum Ducati 959 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Victory Charger Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum
BMW Scrambler Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum